Netsh

This section provides information about Netsh commands and their use:

  • Netsh overview
  • Security information for Netsh commands
  • To enter a netsh context
  • Netsh DHCP example
  • Netsh WINS example
  • Netsh commands


Security information for Netsh commands

Netsh commands are available for some of the networking technologies, and the security issues for each technology are distinct. You can use the links provided to review security issues, considerations, and best practices for each . In addition, you can review the recommendations in Best practices for security.

Technology | Context name | Reference
Dynamic Host Configuration Protocol (DHCP) | netsh dhcp | Security information for DHCP
Internet Authentication Service (IAS) | netsh aaaa | Security information for IAS
Internet Protocol security (IPSec) | netsh ipsec | Security issues with IP
Internet Protocol version 6 (IPv6) | netsh interface ipv6 and netsh interface portproxy | Security information for IPv6
Remote Access | netsh ras | Security considerations for remote access; Security information for VPN
Routing | netsh routing | Security considerations for routing; Security information for VPN
Transmission Control Protocol/Internet Protocol (TCP/IP) | netsh interface ip and netsh bridge | Internet Protocol security (IPSec); Best practices
Windows Internet Name Service (WINS) | netsh wins | Security information for WINS


Enter a netsh context

Microsoft Windows Graphic

To enter a netsh context

  1. Open Command Prompt.
  2. At the command prompt, type:

    netsh

  3. Type one of the following:
To enter this context | Type
AAAA | aaaa
DHCP | dhcp
Network Diagnostics (diag) | diag
Interface | interface
Interface IP | interface ip
Interface IPv6 | interface ipv6
Interface Portproxy | interface portproxy
Internet Protocol security | ipsec
Network Bridge | bridge
Remote Access | ras
Routing | routing
RPC Helper | rpc
WINS | wins

Notes

  • XOX
  • To enter a context, you can type only enough letters in the context name to allow netsh to identify the context. For example, to enter the WINS context from the netsh prompt (that is, netsh>), you can type w, and then press ENTER.
  • Most of the contexts listed above have one or more subcontexts. For more information, see Related Topics.

Related Topics


Netsh commands

This section provides a comprehensive netsh command reference, including syntax, parameters, and examples.

  • Netsh commands for AAAA
  • Netsh commands for DHCP
  • Netsh diagnostic (diag) commands
  • Netsh commands for Interface IP
  • Netsh commands for Interface IPv6
  • Netsh commands for Interface Portproxy
  • Netsh commands for Internet Protocol security
  • Netsh commands for Network Bridge
  • Netsh commands for remote access (ras)
  • Netsh commands for Routing
  • Netsh commands for RPC
  • Netsh commands for WINS